Home > Do I > Do I Need .NET 2.0

Do I Need .NET 2.0

Tags .NET Framework 3.5 setup and deployment .NET Framework 4 .NET Framework setup and deployment Mailbag Visual Studio and .NET Framework Comments (28) Cancel reply Name * Email * Website Michael Plus Microsoft uses it for some functions on their sites. What will it help me, a non-computer specialist, to do? If you don't end up seeing any error messages like this, then you don't need to worry about re-installing the .NET Framework 1.0 or 1.1.

I tried update again, and found nearly 200. You can actually add them to Windows yourself ahead of time if you want by accessing Windows' optional features. Reply Aziman says: October 18, 2013 at 1:05 am thanks for these helpful tips… Reply BH Cheong says: December 14, 2013 at 7:17 am Thank you very much for the informative Is there a similar program out there that doesn't need that program? http://ccm.net/forum/affich-163471-do-i-need-microsoft-net-framework-2-0

As you can imagine, a framework like .NET can be a real boon on the development side of things. Preview post Submit post Cancel post You are reporting the following post: WHAT IS MICROSOFT .NET FRAMEWORK 2.0 & WHAT IS IT NEEDED FOR This post has been flagged and will Since you're dealing with an older OS (XP-Pro) you should get help from Microsoft.

So, you need to go through the process shown in this article to enable support for previous versions of .NET Reply Luriflax January 9, 2013 at 4:42 pm # Thanks, but… When I use this tool, I choose every single item in the drop down list and clean them up. Afterwards, I looked in Add/Remove Programs, and it shows that I have all of the following versions of the .NET Framework installed on my system: Microsoft .NET Framework 1.1 Microsoft .NET I also was going to remove them prior to your information.

The .NET Framework 4 is backward-compatible with applications that were built with the .NET Framework versions 1.1, 2.0, 3.0, and 3.5. share|improve this answer answered Mar 3 '11 at 15:20 Aaron McIver 1,322713 @Shark That's MS covering their hide...the OP should be fine with a .NET 4 install. –Aaron McIver It's kind of big for a dial-up user, and I'm getting low on system resources.somrscov Flag Permalink This was helpful (0) Collapse - Why do you need Driver Detective? https://answers.microsoft.com/en-us/windows/forum/windows_xp-performance/do-i-need-to-keep-both-microsoft-net-framework-20/598894e0-09e1-4906-8ecb-6df5c7d5066f Thank you for helping us maintain CNET's great community.

My vanilla 56K modem is also not working, but has a yellow exclamation mark in Device Manager. In conclusion, I would leave them as it means you won't have issues if you do use software written for specific versions of .NET but if you're absolutely desperate for the Many Thanks in advance. If i build the code in the 4.5 framework is it backward compactable with the .net 3.5 which is already been installed in my XP OS? 2.

Apps written to versions 3.5 and lower will require version 3.5 to be installed, and apps written to version 4 or higher will need version 4 installed. etc. Please try again now or at a later time. Ajay Soni Can I install 4.5 Framework to windows 8.1 64bit?

In other words, applications and components built with previous versions of the .NET Framework will work on the .NET Framework 4. Then check .NET Framework 3.5 (includes .NET 2.0 and 3.0) and click OK. It may find more than that with a single run. My grateful thanks in advance.

Deleting them may cause things to break. @Walter_Glenn Thanks for a nicely written article! --P

May 10, 2016 Walter Glenn @dusters16: I may add that in. Once that is done, restart the computer and rerun Windows updates. Now a word from my disclaimer......proceed at your own risk.This thread untracked Flag Permalink This was helpful (0) Collapse - Net Framework 2.o by Schwartz1 / February 15, 2008 9:46 PM Uninstalling .Net Framework is unlikely to give you more than a few Mb of hard disk space.Mark Flag Permalink This was helpful (0) Back to PC Applications forum 22 total posts

I am not sure you are correct by implying that 2.0 is not installed by installing 3.5 SP1. –harrymc Mar 3 '11 at 14:58 -1 If you have .NET Some of my favorite software requires NET Framework 4.0. which do I need more 2.0 or 3.0?

I can always reinstall if it is required.

Mono is a free and open-source project designed to provide compatibility between .NET applications and other platforms, especially Linux. I bought a used IBM NetVista computer and it came with XP Pro. I will definitely be keeping it. I run the .net3.5 installation package.

Most Commercial software produced by big companies in written in C++ so you probably don't need all the .NET frameworks but any 'smaller' apps, written by private programmers and even some Reply Aaron Stebner says: March 27, 2014 at 3:24 pm Hi Robert Feal-Martinez - Some of the information about replacing/superseding in the Wikipedia article isn't exactly right. Now, I'm stumped... VG ^^ No.

Top NavWindows 10 Forum Featured Articles How To Guides Tech News Reviews Quick Tips Membership Login groovyPost The premier source for tech news, tips, reviews and how to galleries Navigation Home I enabled previous versions of .NET on three different Windows 8 systems and my 32-bit version needed to be restarted. So today, in this topic we'll tell you what is .NET Framework and will also provide official Microsoft download links to download each version of .NET Framework. to install.

Together, these two things meant that developers could now pretty much rely on users having the proper components already installed and no longer had to ask users to perform additional installations. up vote 19 down vote favorite 1 I have 4 Microsoft .NET Framework versions: 1.1 2.0 Service Pack 2 3.0 Service Pack 2 3.5 SP1 Do I need them all? Sadly, I listened to poor advice and had uninstalled the .Net Framework so I could reinstall Office 2007. Get geeky trivia, fun facts, and much more.

If you end up seeing any error messages like this, you can re-install the .NET Framework 1.0 or 1.1 in order to resolve the errors. Make sure you get that service pack 2.0 or IF you're hardware can handle it download the current version of .NetframeHere is .Netframe Linkhttp://www.microsoft.com/downloads/en/details.aspx?FamilyID=333325fd-ae52-4e35-b531-508d977d32a6here is link for XP How To'shttp://windows.microsoft.com/en-US/windows/help/windows-xpYou may Install those updates. .Net framework is required to run many 3rd party software. Flag Permalink This was helpful (0) Collapse - Agree with Bob by MarkFlax Forum moderator / April 22, 2012 4:59 AM PDT In reply to: Microsoft.NET Frameworks 2.0, 3.0, 3.5 all

Track this discussion and email me when there are updates If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and Now it's cross platform, it's even more useful. Join the community here. Thus, you can only uninstall the .NET Framework if you know you do not have/use any programs that require the .NET Framework.

Most applications out there are still built for .NET 2 to 3.5 so installing 3.5 will cover you for that. Reply Saradhi says: February 10, 2014 at 7:27 am i too had 2.0,3.0,3.5 in my xp with sp3. kudos Reply MUBEEN March 3, 2013 at 6:30 am # i have downloaded .netframe work 3.5 but it was not installing even i enabled it in control panel do u have When I search for updates, it just sits there "checking for updates" for hours, but does nothing.

Question: I recently installed the .NET Framework 4 on my system.